All E-Commerce Merchants to be Compliant with the PA-DSS

Posted on 01 July, 2010 by Forrest

Make sure your site is compliant with the PA-DSS in order to be PCI Compliant!! Today marks the official deadline that all online merchants must be using PA-DSS certified applications if you are an e-commerce merchant that processes and/or stores credit card and other confidential information.

Today, June 1st marks the day that all e-commerce websites must ensure that they adhere to the new PA-DSS (Payment Application – Data Security Standard) as established by the PCI (Payment Card Industry). The PCI is composed of all major credit card companies and establishes the guidelines all merchants, payment applications and web hosts must adhere to.

Miva Merchant is now fully PA-DSS certified and added to Visa’s list of compliant payment applications. Therefore, if you are running a Miva 5.5 store with the new Wombat installed, you’re golden and totally protected in case of a security breech.
If you are using a cart that is not compliant with the PCI or PA-DSS certified then you are playing with fire. You risk hefty fines, increased merchant fees and possible shutdown of your site.
Ensure PCI and PA-DSS Compliance by utilizing the PCI Compliant Miva Merchant Web Hosting services provided by WebNet Hosting. We have been a Premer Partner Miva Host since 2004.
Give us a call today 1-877-503-HOST (4678) with any questions or to find out how to upgrade to the latest version of Miva Merchant, which is 100% PA-DSS certified, FOR FREE.

About the Author

Posted on 01 July, 2010 by Forrest